Tuesday, May 28, 2013

Error: The specified module 'WorkflowManager' was not loaded because no valid module file was found in any module directory

All of sudden, on one of the development server, the "Workflow Manager PowerShell" stopped working.  When trying to start it, I got the error message below.

Import-Module : The specified module 'WorkflowManager' was not loaded because no valid module file was found in any module directory.
At C:\Program Files\Workflow Manager\1.0\Scripts\ImportWorkflowModule.ps1:20
char:1
+ Import-Module WorkflowManager
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ResourceUnavailable: (WorkflowManager:String) [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Comm
   ands.ImportModuleCommand

Lucky I have another workflow server which works well. It turns out the "AppFabric server" or "Workflow Manager 1.0" installation & uninstallation caused this issue. The window environment variable "PSModulePath" was changed from

C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\PowerShell\Modules\;C:\Program Files\Service Bus\1.0\;C:\Program Files\Workflow Manager\1.0

to

C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\PowerShell\Modules\;C:\Program Files\Service Bus\1.0\;C:\Program Files\Workflow Manager\1.0"

After removing the double quote at the end of the environment variable value, "Workflow Manager PowerShell" is recovered!



PS: if got error message below during the installation of AppFabric server, possibly we just need to do the same change to window environment variable "PSModulePath".

Call to OpenService(...,SERVICE_START | SERVICE_QUERY_STATUS | SERVICE_STOP | SERVICE_PAUSE_CONTINUE) function to get handle to the service failed (0X424=1060)

No comments:

Post a Comment